FloatingPanel 发布版本: v1.5.0: Support Swift 5.0

Now FloatingPanel supports Swift 5.0. 🎉✨✨ #177 See also README > Requirements 👍

All examples are upgraded to Swift 5.0, but the default Swift version of the library leaves Swift 4.0 because it avoids build errors with Carthage on each Xcode version from the source compatibility between Swift 4.0, 4.2 and 5.0. (All of Xcode 9.4.1+ support Swift 4.0)

With regard to CocoaPods, for now, a user needs to override SWIFT_VERSION appropriately in Podfile. But after CocoaPods v1.7.0, the pod spec is going to support swift_versions key and then you won't need it.